Change active language

Support for the WordPress Calendar plugin
mifl
Posts: 1
Joined: Thu Feb 07, 2013 8:49 am

Change active language

Unread post by mifl » Thu Feb 07, 2013 8:59 am

Have edited calendar.pot but the changes take no affect. How to update for my new file to be activated?

User avatar
Kieran
Posts: 2058
Joined: Sat May 26, 2007 1:55 pm
Location: London
Contact:

Re: Change active language

Unread post by Kieran » Fri Mar 01, 2013 8:24 pm

Rename the file to be "calendar-en_GB", where "en_GB" is to be replaced with your locale. Then change the extension to .po Finally run a conversion of po to mo (search google for how to do this in various operating systems) and upload the mo file, named "calendar-<locale>.mo" and it should start working

roni
Posts: 1
Joined: Fri Nov 20, 2015 2:10 pm

Re: Change active language

Unread post by roni » Fri Nov 20, 2015 2:58 pm

Hi Kieran,

I have trouble making the exchange of language, English to Portuguese of Brazil, I'm not finding where I can change, I found a directory with the calendar-pt_BR.po files and calendar-pt_BR.mo.
Excuse me, but I did not understand your last answer this question, since there are already the .po and .mo files.
Please help me as I make this transition.
Thank you,

User avatar
Kieran
Posts: 2058
Joined: Sat May 26, 2007 1:55 pm
Location: London
Contact:

Re: Change active language

Unread post by Kieran » Fri Nov 20, 2015 10:22 pm

With the latest version of calendar there are bundled translations. To use them, you just need to make sure that the locale of your WordPress install is set to the same as the locale you want to use in the bundled calendar/languages directory

Silv
Posts: 1
Joined: Fri Jan 15, 2016 4:39 pm

Re: Change active language

Unread post by Silv » Fri Jan 15, 2016 7:26 pm

I'm truly sorry, but it still doesn't change the language.
I'm using Estonian version of WP and on options-general page Estonian is selected and al the menus are in Estonian. So the locale should be correct.
The folder for language files has also calendar-et_EE.mo and calendar-et_EE.po files but calendar is still in English.

Is there any way to check why it doesn'd use language according to locale or is there some workaround to force calendar to use Estonian. Probably the hardest way is to modify php files. :)

User avatar
Kieran
Posts: 2058
Joined: Sat May 26, 2007 1:55 pm
Location: London
Contact:

Re: Change active language

Unread post by Kieran » Sun Feb 18, 2018 8:30 pm

Two things to check

1) Is the locale definitely et_EE
2) When you say you have placed the language file in the directory, I assume you mean the calendar plugin language directory and not that for WordPress?

Post Reply